Issue

Devices enrolled in Netsanity will not be able to play Netflix or Amazon videos.  They will receive an error or the video will not play.  


Cause

Netsanity has added a new Enhanced VPN to all its global markets. New customers (after Jan 1st, 2018) will automatically get the new Enhanced VPN as their default VPN. Netsanity will also to continue to support and offer the Legacy VPN for customers that prefer to keep the Legacy VPN, as there are considerations for some customers to switch to the Legacy VPN.


NETFLIX, Amazon Video and some other video streaming services will not work with Netsanity's Enhanced VPN. They block most VPN's to avoid customers streaming content illegally from other countries. Netsanity gives customers 2 options to address this issue. 


Solution / How To Change Your Current VPN Type

Customers can change their preferred VPN type anytime with a simple toggle. The device has to be unlocked and connected to the internet. After a few seconds, a new VPN profile will be delivered to the device. During this process the VPN icon will disappear and reappear again - this is normal.


  1. Log into your dashboard located at https://my.netsanity.net
  2. Select Manage Device next to the device you would like to change the VPN type.
  3. Simply switch "Enhanced" to "Legacy".
  4. Netflix and Amazon Prime Video will be able to be played within minutes on the device.